Google Translate Outage (Investigating)

Incident Report for Apptegy

Resolved

This incident has been resolved on Google's end.
Posted Jun 12, 2025 - 20:54 CDT

Identified

We are actively monitoring the situation, but are seeing minimal effects on our system.

Thank you for your continued patience and please check back at status.apptegy.com for the most recent updates!
Posted Jun 12, 2025 - 17:58 CDT

Investigating

Apptegy is currently investigating an issue that is impacting translations. We primarily use Google Translate for our service, and Google is currently experiencing a large scale outage.

We are working to gather more information and will provide an update as soon as we know more. We are seeing elevated error rates on translation, but the features may still function for some users.

We appreciate your patience and will continue to keep you updated at status.apptegy.com!
Posted Jun 12, 2025 - 13:57 CDT
This incident affected: Third Party Services.