Documents are inaccessible for some regional ISP users

Incident Report for Apptegy

Monitoring

We have contacted the relevant internet service providers exhibiting this issue in order to share our findings. We are now awaiting confirmation that they are taking the actions necessary to resolve the DNS resolution errors.
Posted Apr 17, 2026 - 11:29 CDT

Investigating

We are currently investigating an issue where some users are unable to access documents. Our initial findings indicate that this is isolated to specific regional internet service providers. The issue appears to be related to the provider's default DNS servers failing to resolve some AWS content. We will follow up with additional information as it becomes available.
Posted Apr 17, 2026 - 10:21 CDT
This incident affects: Media/CMS and Other Services.