Duplicate Alert deliveries reported

Incident Report for Apptegy

Resolved

We have completed our investigation into the duplicate Alerts sent between 4:15 PM and 4:45 PM CDT on April 20, 2026. A deployment unexpectedly restarted a small number of previously queued jobs, resulting in Alerts originally intended for April 15th to be sent on April 20th. We have implemented updated expiration rules that will prevent this from occurring again in the future.
Posted Apr 21, 2026 - 09:43 CDT

Investigating

We are investigating reports of duplicate Alerts sent between 4:15 PM and 4:45 PM CDT today (April 20th) that appear to be repeats of Alerts originally sent on April 15th. We will follow up with additional information as it becomes available.
Posted Apr 20, 2026 - 18:01 CDT
This incident affected: Alerts.