Announcement Creation on iOS inconsistently available for Staff users

Incident Report for Apptegy

Resolved

The Apptegy for Staff app update has been published to the App Store: https://apps.apple.com/us/app/apptegy-for-staff/id1024147876

This has resolved the issue where staff were intermittently unable to create new Announcements.
Posted Dec 05, 2025 - 16:31 CST

Identified

We have identified an issue that may prevent staff users from creating new Announcements within Rooms on iPhone in the Apptegy Staff app (Thrillshare Mobile). Our team has identified a resolution and submitted the updated version of the app to Apple for approval. We expect that this update will be available within the App Store no later than the end of the day Monday, December 8.
Posted Dec 05, 2025 - 15:35 CST
This incident affected: Rooms.