Engage Newsletter editor may not successfully save changes

Incident Report for Apptegy

Resolved

This issue has been resolved as of 1pm CDT. Editing Newsletters is now functioning properly.
Posted Jul 16, 2026 - 13:19 CDT

Identified

We have identified an issue where some users may not be able to save changes they've made within Newsletters. Our team has confirmed that this issue is related to one of our third party providers and is working with them to resolve this as quickly as possible. We will update this status no later than 1:30pm CDT.
Posted Jul 16, 2026 - 12:31 CDT
This incident affected: Engage and Third Party Services.