The broader service disruptions caused by the AWS US-EAST-1 region outage have been fully resolved. The incident impacted several third-party dependencies that Apptegy services rely on.
All systems are now operating normally. We will continue to monitor for any residual effects and appreciate your patience during this time.
Posted Oct 20, 2025 - 22:30 CDT
Update
We are seeing improvements in the login experience on iOS (Apple) devices for users attempting to access District mobile apps. We will continue to monitor the situation through tomorrow morning.
Posted Oct 20, 2025 - 22:18 CDT
Monitoring
We are continuing to monitor the AWS Outage and it's impact on our platform and other third party vendors.
Posted Oct 20, 2025 - 16:41 CDT
Identified
Apptegy has identified the root cause of the issue, which appears to be related to Amazon Web Services, a third-party service our system relies on.
This may cause issues logging into Thrillshare and cause delays in response times for support.
Amazon Web Services (AWS) is used broadly and is impacting services many applications rely on to maintain connections to users and data, and as such may impact data for Alerts and Rooms as well as website availability.
We are actively monitoring the situation and working to mitigate impact where possible. We’ll continue to post updates as we learn more or as the situation changes.
Thank you for your continued patience and please check back at status.apptegy.com for the most recent updates!